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This manual is intended to assist operating personnel in becoming familiar with the product and as 
guidance in ordering necessary parts inclusive of SuperFlow's warranty requirements. Maximum operating 
efficiency and life of any SuperFlow product will be attained through complete understanding of the 
instructions and recommendations contained within this manual.

Services  performed beyond preventive maintenance 
by personnel other than SuperFlow Service 
Technicians on any SuperFlow products during the 
warranty period may void the warranty. 

WARNING

 

When available, please include the model 
number and serial number of the product in any 
correspondence.

IMPORTANT
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1.0 System Overview
1.1 Data Acquisition and Control System Components
The system is divided into three groups: the Commander computer, the PowerPro-SF Controller, and 
optional components.

Commander Computer
This terminal communicates with the Sensor Interface Device and the dynamometer. 
From the Commander Computer, the user can monitor the engine and 
dynamometer performance through the customizable virtual dashboard. It is also 
the location where new tests and reports are generated, manipulated, stored, run, 
and printed.

Sensor Box
The Sensor Box is used to interface data from the engine and dynamometer into the 
Commander computer. 

Sensors
Information is gathered from a variety of sensors attached to either the engine or 
dynamometer.

 ▪ Pressures
 ▪ Fuel Flow
 ▪ Temperatures: EGT, Low Temp.
 ▪ Speed

Optional Components
Super Flow offers a wide range of optional components and accessories for the PowerPro-SF Data 
Acquisition and Software System, including:

 ▪ ECM Communicator
 ▪ Fuel Measurements
 ▪ Additional Sensors: Temperature, Pressure, Vibration, Speed, Crank Blow By
 ▪ Smoke Opacity Meters
 ▪ Five Gas Analyzer
 ▪ Electronic Throttle Interfaces
 ▪ Auxiliary Outputs
 ▪ Alarms
 ▪ PC Upgrades

Our in-house manufacturing and electronics department guarantees that we will be able to provide data 
acquisition and control system accessories for nearly any application. For more information, contact your 
Super Flow representative, or visit us on the web at www.superflow.com.
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1.2 Software Overview
The PowerPro-SF Software Package is a complete data acquisition and control program for dynamometers 
and engines. PowerPro-SF transforms a standard computer and specially designed electronic components 
into a highly efficient development and qualification tool.

The software is comprised of several programs running at the same time: the Main Display, PowerPro-
SF Interface, Pattern Runner, and Report Generator. There may be other programs running minimized in 
the background (operational, but hidden) according to what is listed under the Add-Ins menu of the Main 
Display.

Main Display PowerPro-SF Interface

Pattern Runner Report Generator

Depending on the operating system used, the 
software may have a slightly different appearance 
compared to the examples shown in this manual. 
This does not affect the performance of the 
program in any manner.

IMPORTANT

1.0 System Overview
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Main Display
The Main Display contains the readings for all of the available 
visible sensors. All of the sensor parameters and 
configurations can be modified from this window by right-
clicking on the individual sensor readings. Additionally, this 
window is used to open and save Templates and 
DataSpaces, as well as exit the program. The details of the 
functions and features of the Main Display are discussed in 
Chapter 3.

PowerPro-SF Interface
The PowerPro-SF Interface provides essential control 
functions for the dynamometer. This window identifies the 
dynamometer’s active load control mode and the current 
setpoint. It is possible for a user at the Commander computer 
to control the dynamometer and engine using the mode 
buttons and the input box directly from the PowerPro-SF 
Interface. The details of the functions and features of the 
PowerPro-SF Interface are discussed in Chapter 4.

Pattern Runner Interface Window
The Pattern Runner program allows the user to create, load, 
save, and execute Patterns. Patterns are pre-configured 
tests that are designed to run in a specific order. The details 
of the functions and features of the Pattern Runner are 
discussed in Chapter 5.

Report Generator Interface Window
The Report Generator allows the operator to arrange the 
data into a meaningful visual format. The data can be 
arranged as spreadsheets and/or graphs, while any customer 
and vehicle information can be put into paragraphs and/or 
tables. The details of the functions and features of the Report 
Generator are discussed in Chapter 6.

1.0 System Overview
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1.3 The PowerPro File System
The PowerPro File System consists of the following components: Templates, DataSpaces, and Patterns. It 
is important to understand the function of each of these file types.

Templates (.tds)
A Template is a file containing pre-configured, basic test information. All Templates can be customized with 
information applicable to the kind of test you want to perform. This may include sensor configurations and 
report formats and Patterns. Templates are created by the administrator and do not contain any data. Once 
a test is performed, data can then be collected and saved in the form of a DataSpace.

DataSpaces (.pds)
After a Template has been used to acquire data, it is then saved as a DataSpace. A DataSpace contains 
the same information as the Template with the addition of specific test data. A DataSpace is utilized 
whenever an operator wants to save new test data or recall data from a previously saved test and is the 
area where live data is stored.

Patterns (.pcp)
Patterns are pre-configured tests that are designed to run in a specific order. Patterns are created by the 
administrator and they can be saved within a Template or as individual files to be loaded into existing 
Templates.

Tuning Files (.pct)
Tuning Files are individual files storing dynamometer tuning parameters. The tuning parameters should not 
be modified unless otherwise instructed to do so by SuperFlow.

ECM Information (.pei)
Specific vehicle ECM communication configurations can be saved and loaded as individual files.

All file types should be stored in the C:\Power Test\
Commander 2.0 directory.

IMPORTANT

1.0 System Overview
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List of Sensors
The PowerPro System incorporates numerous sensors. Some of them are shown on the screen and others 
are invisible. As stated previously, by right clicking on a visible sensor and selecting “Hide”, you can hide 
the sensor. To make an invisible sensor appear, go to View > More Sensors and check the check box 
indicating that sensor. All sensors in a typical PowerPro system are listed below. Depending on the method 
to get the sensor’s value, those sensors are listed in two groups: Direct Sensors and Calculated Sensors. 
In addition, Typical System Input Data are listed at the bottom of this page.

Direct Sensors: These values are directly determined by the data captured by the physical sensors.

 ActTorque: The actual torque value from the strain gauge load cell.

 Speed: Speed data directly from speed pickups. The speed range is 0-14000RPM.

 Temp(1-5): Temperature data from low temperature sensors ( range 32-300 degrees F).

  EGT(1-12): Engine exhausted gas temperature data from K type thermocouples. (range 200-1600 
degrees F).

 Press(1-4): Pressure data from pressure gauges. (two 0-200PSI, many other ranges available).

 FREQ(1-3): Frequency data from frequency sensors. (For PowerPro Plus only).

  AUX(1-3): Show the data from AUX. (Only AUX1 is available for PowerPro; AUX(1-3) are available for 
PowerPro Plus)

Calculated Sensors: These values are determined by calculation.

  Torque: The compensated torque value. Torque=ActTorque+Inertia Torque. (Inertia 
Torque=Inertia*Acceleration)

 Power: Power value, which is calculated by multiplying torque by speed. Power=Speed*Torque.

 Acceleration: Acceleration value, which is calculated based on speed and time.

 FuelFlow: Fuel volume flow data from fuel flow meter(s).

 AirMassFlow: Air mass flow value from mass air flow sensors.

 FuelMassFlow: Fuel mass flow. FuelMassFlow=fuel volume flow *fuel density.

 AirDensity: Air density, which is calculated based on air temperature, bar pressure and humidity.

 AirFlow: Air volume flow. AirFlow=AirMassFlow/ AirDensity.

1.0 System Overview
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1.0 System Overview
  VolEff: The ratio of Max. possible air flow through vs. actual air flow measure. VolEff=AirFlow/Vol per 

Rev.

 AFR: Air/Fuel ratio. AFR=Mass Air Flow/Mass Fuel Flow.

 CorrFactor: The correction factors calculated based on correction files and weather conditions.

 CorrHp: Corrected power. CorrHP=Power*CorrFactor.

 CorrTorq: Corrected torque. CorrTorq=ActTorq*CorrFactor.

 BSFC: Brake Specific Fuel Consumption. BSFC=Mass Fuel Burn rate/HP. The unit is Lbs/Hp.hr.

  CSFC: Corrected Specific Fuel Consumption. CSFC=Mass Fuel Burn rate/Corrected HP. The unit is 
Lbs/Hp.hr.

 BSAC: Brake Specific Air Consumption. BSAC=Mass Air Burn rate/HP. The unit is Lbs/Hp.hr.

  CSAC: Corrected Specific Air Consumption. CSAC=Mass Air Burn rate/Corrected HP. The unit is Lbs/
Hp.hr.

 Elapsed Time: Time stamp of recorded data. (accuracy<1ms).

System Input Data: To make the system work properly, certain data needs to be inputted by users.

 Inertia Value: User inputs value required.

 Sweep Test Start RPM: User inputs value required.

 Sweep Test End RPM: User inputs value required.

 Sweep Step Size RPM: User inputs value required.

 Fuel Density (specific gravity): Requires input from user.

 Inlet Air Temperature: Requires input from user or an optional sensor.

 Barometric Pressure: Requires input from user or an optional sensor.

 Relative Humidity: Requires input from user or an optional sensor.

 Frictional Torque: Percentage per SAE.

 Volume of Displacement/Revolution: User inputs desired value.
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2.1 Before You Begin
The PowerPro Data Acquisition software is based on the Microsoft Windows operating system. Successful 
operation of the PowerPro software requires basic knowledge of the Windows operating system and 
familiarity with operating a keyboard and mouse.

If you are not familiar with basic computer operations, classes can often be found at your local library or 
school district. Additionally, there are numerous instructional books that can be found at the local library, 
book store, or on-line retailer.

Important Terms and Functions
The PowerPro File System consists of the following components: PowerPro Templates and PowerPro 
DataSpaces.

PowerPro Template (.tds)
A Template is a file containing pre-configured, basic test information. All Templates can be customized with 
information applicable to the kind of test you wish to perform. This may include sensor configurations, test 
settings, and report formats. Templates are created by the administrator. 

You can create and save as many different Templates as are desired. A Template is often created for each 
type or style of engine.

Templates do not contain any data. Once a test is performed, data can then be saved in the form of a 
DataSpace.

PowerPro DataSpace (.pds)
After a Template has been used to acquire data, it is then saved as a DataSpace. A DataSpace contains 
the same information as the Template with the addition of specific test data. A DataSpace is utilized 
whenever an operator wishes to save new test data, or recall data from a previously saved test and is the 
area where live data is stored.

A DataSpace can be reopened to run additional sweeps or make modifications to the Report. You can save 
this new information, overwriting the current file, or save it as a new DataSpace.

Saving a File
There are two options for saving a file: Save and Save As. 

Save: Saves the current active DataSpace or 
Template, overwriting the current file.

It is recommended that you avoid using the Save 
function until you are very familiar with the way the 
software operates. You can use the Save As option 
to save as many new files as needed.

Use caution when using the Save function. Once 
changes have been saved and the original file 
has been overwritten, the original file cannot be 
retrieved.

IMPORTANT

2.0 Basic Operation
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2.2 Starting the Commander Computer
Once the Commander computer and all related components have been installed and set up by your 
SuperFlow representative, you are ready to turn on the Commander computer. Make sure the monitor and 
printer are also on at this time.

 PowerPro Splash Screen              Default PowerPro-SF Template

The computer should automatically execute the PowerPro-SF program and the splash screen (top left) will 
become visible during the time the program is loading. If the software ever needs opening, the program can 
be launched by double-clicking on the “P” icon on your desktop background.

If the program does not automatically start or the 
icon does not appear, contact your Power Test 
representative.

IMPORTANT

Once you have powered up (for operators) or logged in (as an administrator), the default Template should 
be loaded and visible (top right). To log in to the system, select Log-in from the PowerPro-SF menu bar.

For administrative functions, a log-in name and 
password are required.

IMPORTANT

2.0 Basic Operation
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Logging In
The Log-In is found in the pull-down menu of the Main Display. The pull-down menus are located in the 
header of the Main Display when using the Single Main Form format or found in a floating window if the 
Floating Form format is used.

File > Log in: Opens the Log-in screen so an 
administrator can sign in and perform administrative 
functions.

As installed from the factory, the default user name 
and password is the word ADMIN. Changing the 
password and assigning new users and passwords is 
performed using the Security Editor function found in 
the Add-ins section, as discussed in Chapter 7.

Without logging in, many menu items will be grayed 
out and the corresponding administrative functions 
cannot be performed. All functions requiring log in 
will be noted with an * throughout the rest of this 
manual.

IMPORTANT

Typically, the operator will open one of several Templates created by the administrator based on the type of 
engine or test being performed.

2.0 Basic Operation
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2.0 Basic Operation
2.3 Test Procedure
Once the engine has been prepared for testing, including mounting the engine to the engine cart/stand 
and installation of all components (flywheel, engine adaptors, drive shafts, engine cooling system, etc.), 
the next step of the process is to perform the actual engine test. Once the safety and integrity of all of 
the systems, connections, supplies and the engine are verified, you are ready to begin. The following 
information outlines a typical test sequence.

Prepare for Testing
1. Turn ON the Sensor Box
  To turn ON the Sensor Box, press the ON/OFF button on the front panel. The green LED will indicate 

power.
2. Turn ON the Commander Computer
  Turn ON the computer, monitor and printer. The PowerPro-SF Data Acquisition Software will load 

automatically.
3. Enter in Your User Password
  Login to the systems from the Main Display menu. Enter your assigned user name and password.
4. Open a PowerPro-SF Template
  Open an appropriate template by selecting File > Open > Template from the Main Display. This 

Template is typically named by engine model. If an appropriate Template does not exist, one must be 
created. More information on creating Templates can be found in Chapter 3, Main Display.

5. Calibrate Throttle
 Verify engine throttle connection and adjustment depending on individual setup.
6. Turn ON the Support Systems
  Turn ON the water recirculation system (if applicable), including cooling columns, pumps, etc. 

Additionally, ensure that all ventilation equipment is operable. Turn ON the Fuel System. Once the 
throttle has been calibrated and the support systems have been turned ON, start the engine.

7. Begin Testing
 Test the engine as specified by your supervisor.

After Testing is Completed
1. Turn OFF the Engine 
 Once the testing session has been completed, shut down the engine
2. Turn OFF the Support Systems 
3. Edit Data
  Enter any test specific data using the Report Generator program. Use the Print Preview function to view 

the edited report.
4. Save Test Data
  From the Main Display, click File > Save As > Data Space. Assign a file name, typically determined 

by work order #, etc. If desired, print a hard copy of the report by selecting File > Print from the Main 
Display menu.

5. Shut down the Commander Computer 
 Shut down the computer by clicking File > Shut Down System in the Main Display window.
6. Turn OFF the Sensor Box
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3.0 Main Display
3.1 The Main Display Window
The Main Display window contains all of the sensors that are connected to the system. These sensors 
can be displayed in two formats. The Single Main Form format displays all of the individual gauges in a 
fixed format. The Floating Form format allows the user to customize the size and location of the individual 
gauges on the screen.

Example of the Single Main Form Format

Example of the Floating Form Format
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The illustrations throughout the rest of this manual 
will display sensors in the Floating Form format. 
This may or may not represent how your system is 
configured.

IMPORTANT

3.2 Main Display Window Pull-Down Menus
The pull-down menus are located in the header of the Main Display when using the Single Main Form 
format or found in a floating window if the Floating Form format is used. (If the Floating Form format is 
selected, the full pull-down menus will appear by putting your cursor on the “P” icon.) The pull-down menus 
consist of: File, View, Data, Window, Add-Ins, and Help.

Single Main Form Pull-Down Menu

“P” Icon and Floating Form Pull-Down Menu

The File Menu
From the File menu, many of the file management tools needed to operate the software can be 
accessed. The File menu consists of: Login, Open (Template or DataSpace), Save, Save As (Template or 
DataSpace), Revert to Saved, Shut Down System, and Exit.

File > Log in: Opens the Log-in screen so an 
administrator can sign in and perform administrative 
functions.

Without logging in, many menu items will be grayed 
out and the corresponding administrative functions 
cannot be performed. All functions requiring log in 
will be noted with an * throughout the rest of this 
manual.

IMPORTANT

3.0 Main Display
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*File > Open > Template or DataSpace: Loads         an 
existing Template used to run a pre-configured test. If 
not logged in, the user will only have the option of 
opening a Template within the program directory. If 
logged in, the user will have the ability to search the 
entire computer and all removable drives for a 
Template. Clicking DataSpace loads an existing 
DataSpace that contains previously saved test data.

*File > Save: Saves the active Template or 
DataSpace; overwriting the current file.

Once changes have been saved and the original 
file has been overwritten, the original file cannot be 
retrieved.

IMPORTANT

File > Save As >Template or DataSpace: Saves the 
active Template or DataSpace as a new Template or 
DataSpace. The user will be prompted to name the 
new file before saving. In addition to the new file being 
saved to the system, the original file will still exist.

File > Revert to Saved: Ignores recent changes in the 
active Template or DataSpace and reverts back to the 
previously saved version.

File > Shut Down System: Closes the software 
program and powers down the Commander computer.

3.0 Main Display
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File > Exit: Closes the program and returns the user 
to the Windows Desktop. If changes have been made 
to the active Template or DataSpace, the user will be 
given the option of saving the changes before closing 
the program.

The View Menu
From the View menu, hidden sensors can be made visible and the sensor layout can be changed. The 
View menu consists of: More Sensors, Display Layout, Chart, Find Overlapping Sensors, and Lock Sensor 
Positions.

View > More Sensors: Produces a pop-up window 
(below) that allows the user to make hidden sensors 
visible. Check the boxes of the sensors you want to 
show and click OK.

                 

A sensor does not have to be visible for its data to 
be recorded and/or shown in the report.

IMPORTANT

View > Display Layout: Clicking Display Layout will 
automatically open the Sensor Order window, which 
has two tabs: Sensor Order and Sensor Configuration. 
Both tabs are described in greater detail on the 
following pages.

3.0 Main Display
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Sensor Order Tab

  View menu > Display Layout > Sensor Order tabFastFind»»

Sensor List

Move Sensor Position Up

Move Sensor Position Down

To change the order in which sensors appear in the Single Main Form format, click on the Sensor Order 
tab. Highlight a sensor by clicking on it and use the navigational buttons at the right of the window to move 
the selected sensor. Click OK when finished to save the new sensor order or click Cancel to disregard 
changes. The Sensor Order tab displays a list of all the sensors in the order they appear in the Single Main 
format.

The Sensor Order function will not work if all 
sensors are displayed in the Floating Form format.

IMPORTANT

Sensor Configuration Tab

	 View	menu	>	Display	Layout	>	Sensor	Configuration	tabFastFind»»

There are two formats to display the sensors: Single Main Form and Floating Form. In the Single Main 
Form format, all of the available sensors are grouped together in the Main Display window. In the Floating 
Form format, sensors can exist anywhere on screen and can be sized individually. The use of the Floating 
Form format allows a highly customizable appearance to the Main Display. A Single Main Form and 
Floating Form can exist together.

3.0 Main Display
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From the Sensor Configuration tab, the user can select how many sensors appear in each row of the Main 
Display using the Single Main Form format, as well as how many sensors will be displayed in the Single 
Main Form format and how many in the Floating Form format.

If the 3 on top row (stationary) 5 on remaining rows 
option is selected, a Single Main Form will display three 
sensors in the top row and five sensors in each row 
thereafter until all sensors are displayed. If selected, the 
sensors in the first row will all be square in shape.

If the 4 on top row (stationary) 5 on remaining rows 
option is selected, a Single Main Form will display four 
sensors in the top row and five sensors in each row 
thereafter until all sensors are displayed. If selected, the 
sensors in the first row will all be square in shape.

If the 5 on top row (stationary) 5 on remaining rows 
option is selected, a Single Main Form will display five 
sensors in the top row and five sensors in each row 
thereafter until all sensors are displayed. If selected, the 
sensors in the first row will all be square in size.

If the 5 on all rows (non-stationary) option is selected, a Single Main Form will display five sensors in 
each row. If selected, each sensor will be equal in size, regardless of number selected.

The Sensor Display frame of the Sensor Configuration tab is used to determine how many sensors will be 
displayed in the Single Main Form format and how many in the Floating Form format. 

To display all sensors in Single Main Form format, 
click on the All Sensors check box. To have all 
sensors display in the Floating Form format, 
uncheck the All Sensors check box and enter the 
number zero into the Number of Sensors on Main 
Form input box.

IMPORTANT

To display sensors in both a Single Main Form and Floating Form format, enter the number of sensors 
that should remain in the Single Main Form format in the Number of Sensors on Main Form input box. ex. 
If there are 13 sensors available and six is entered into the Number of Sensors on Main Form input box, 
then six sensors will be displayed in the Single Main Form and the remaining seven sensors will exist as 
Floating Forms.

3.0 Main Display
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To change which sensors appear in the Single Main Form, click on the Sensor Order tab and rearrange the 
sensors so that the ones you want in the Single Main Form appear at the top of the list. ex: If you want six 
specific sensors in the Single Main Form, click on the Sensor Order tab and, using the navigational buttons, 
bring those six sensors up to the top six positions in the list.

To move a sensor's position in the Floating Form format, confirm that the Lock Sensor Positions option 
in the View drop-down menu is unchecked. If it is checked, click on Lock Sensor Positions to unlock the 
sensors. (Clicking on Lock Sensor Positions will check or uncheck that option.) Next, click on the sensor 
and drag it to its new location. To change the size of a sensor, click on an edge or corner of the sensor 
window and drag it to the desired size. Once all sensors have been placed, click on Lock Sensors Positions 
from the View menu, which will lock the sensors in their current position and help to avoid the possibility of 
accidentally moving, re-sizing, or hiding a sensor.

Sensor Properties

	 	With	the	mouse,	right-click	on	any	of	the	sensors	on	the	Main	Display	and	select	
Properties.FastFind»»

Properties: Selecting Properties will open the Sensor Properties window.

Hide: Selecting Hide will remove that sensor from the Main Display window and 
return it to the list of sensors under View > More Sensors. To add the sensor back, 
go to View > More Sensors and select the sensor you want to display.

Sensor Properties Window: The Sensor Properties window contains five tabs that allow the user to 
customize the sensor. The tabs are: Gauge, Display, Units, Low Alarm, and High Alarm. In addition, the 
name of the sensor can be changed by entering the new name into the Sensor Name input box. 

When sensor property edits have been completed, 
select OK to save changes or Cancel to disregard 
any changes.

IMPORTANT

Properties > Display Tab: This is where the operator can select which type of 
gauge should be displayed for a sensor. The operator can select from a Digital, 
Round Dial, Sweep Dial, or Bar gauge (shown below). However, the Bar gauge is 
only available in the Floating Form format.

     
      Digital  Round Dial  Sweep Dial        Bar

3.0 Main Display



18

4060 Dixon Street ▪ Des Moines, IA 50313 USA 
phone: (515) 254-1654 ▪ fax: (262) 246-0436

www.superflow.com

Properties > Gauge Tab: This tab provides the operator with 
options to define the displayed range and multiplier for the gauge. 
The Maximum Reading establishes the top or highest number 
displayed in a Dial or Bar gauge. The Minimum Reading 
establishes the bottom or lowest number displayed in a Dial or 
Bar gauge. The Display Multiplier is the number by which the 
numbers in a display are divided by. ex. A multiplier of ten will 
display 1000 RPM as 100 RPM. This will also change the display 
unit to RPM x 10 (or whichever multiplier is chosen). The Decimal 
Places without Display Multiplier is the number of decimal places 
that are displayed as determined by the number entered in the 
input box. ex. If a value of three is entered in the input box, data 
will be displayed to .000 or thousandths.

Properties > Units Tab: This is where the user defines the unit 
properties for the gauge. Standard units can be chosen by 
selecting Use List and picking from the drop-down menu. To 
define a custom unit, select Custom and enter a unit name, 
description, and display symbol. Enter the values that the 
sensor’s standard unit must be multiplied by and/or added to, to 
achieve the custom unit. Once all the information is entered, the 
custom unit can be added to the list of standard units. To find the 
base unit, choose from the Use List until you find one with an 
adder of zero and a multiplier of one (usually the first listing).

Properties > Low Alarm/High Alarm Tabs: These tabs are 
where the user defines what actions (explained on page	19) will 
be taken during a Low Alarm/High Alarm state.

3.0 Main Display
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3.0 Main Display
Alarms

	 	With	the	mouse,	right-click	on	any	of	the	sensors	and	select	Properties.	Then	
click	on	either	the	Low	Alarm	tab	or	High	Alarm	tab.FastFind»»

Sensors displaying readings with an optimal range (an administrator defined normal range) will display in 
grey. Sensors that have fallen below their operational range (low alarm) will display blue. Sensors that have 
exceeded their operational range (high alarm) will display red. 

As soon as the sensor travels outside of its operational range, it will change color and there will be two 
options available to the operator: Hold (suspend) or Reset the alarm. If the Hold button is clicked during 
the alarm state, the software will suspend the alarm action for the period of time indicated in the Suspend 
Time input box. Reset clears the alarm condition. To remove the condition, simply click on either the Hold 
or Reset function buttons. 

The operator has the following options when setting a low alarm or high alarm: Trigger Point, Wait Secs 
Before Action, Suspend Time, Grab Data if Triggered, Auto Reset, and Action.

Trigger Point: The value at which the software will indicate that the sensor is out of the operational range. 
The units of the value entered are selected from the Units tab. For example, if the sensor is configured in 
rpm, then the value entered will reflect rpm.

Wait Secs Before Action: Indicates how many seconds the software should wait before performing the 
alarm action.

Suspend Time: Indicates how long the alarm action will be delayed (in seconds) if the Hold button is 
clicked.

Grab Data if Triggered: If checked, the software will immediately grab data if the trigger point is reached. 
Grabbing data once a trigger point has been reached will help identify the problem area and cause of the 
alarm. If Grab Data if Triggered is not checked, the data will not be gathered at the point of alarm.

Auto Reset: If checked, the software will automatically reset the alarm after the sensor limit has returned 
to normal.

Action: The action state of the alarm allows the administrator to set the following actions to be performed 
by the software after the number of Wait Secs Before Action has completed:

  Action > None: Indicates no action is to be performed and only a color change is indicated on the 
screen.

  Action > Soft Stop: When the alarm is triggered, the software will first apply the Wait Secs Before 
Action value, then perform a soft stop. Both the speed control and the dynamometer control return 
to zero and the stop relays fire automatically. These actions stop the engine as if it were shut down 
normally, as no load is applied during a soft stop. If selected, an alarm will sound.
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  Action > E Stop: If an E stop is triggered, the throttle returns to zero and the valve is fully opened, 
applying a preset load to the engine. The stop relays are fired and the engine is brought to an abrupt 
stop. If selected, an alarm will sound.

  Action > Warning Only: In this condition, only an alarm warning is displayed on screen; no actions are 
performed.

View > Chart: By selecting Chart, the Real-Time Chart 
(middle right) will be displayed. This chart displays the 
real-time data change. Additionally, reference data can 
be viewed on the Real-Time Chart.

To customize the Real-Time Chart, right-click on the 
chart and choose Properties, which opens the Chart 
Properties window (bottom right). To hide or close the 
Real-Time Chart, right-click on the chart and choose 
Hide.

If the user opens the Chart Properties window they 
will have the option to choose what information will 
appear on the X-Axis (horizontal) and Y-Axis (vertical) 
of the chart. Within the Points frame, the user is able 
to select how many points appear in the Real-Time 
Chart. The number of points (30, 60, or 120) will 
determine the actual width of the chart. Within the 
Speed frame, the user can select the speed (Medium 
or Fast) at which the system updates and displays 
data. The actual ranges of the chart are determined by 
the minimum and maximum values of the sensor as 
established in the Sensor Properties window.

To display the information from the current, active 
DataSpace as it is being recorded, select Rolling 
Time Chart from the X-Axis pull-down menu. If 
Rolling Time Chart is selected, the chart will scroll 
from right to left as selected Y-Axis data is being 
displayed.

Selecting the Chart Reference Data check box will display reference data on the chart in addition to data 
from the current, active DataSpace. More information on reference data can be found on page	22 and in 
Chapter	7.3,	Add-In	Programs.

Real-time graphing consumes a greater amount of 
processing power as the speed rate and number of 
sensors are increased.

IMPORTANT

3.0 Main Display
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View > Find Overlapping Sensors: This menu         
item will be active only if there are sensors displayed 
as Floating Forms. In this format, some visible sensors 
may be overlapped by other sensors. This selection 
will point out the positions of overlapped sensors and 
mark them with the Overlap symbol. Clicking the 
Overlap symbol will cause the overlapped sensor to 
appear.

View > Lock Sensor Positions:
This menu item will be active only if there are sensors 
displayed as Floating Forms. Normally, sensors 
in Floating Forms can be any size or positioned 
anywhere on the screen. Checking this menu item will 
disable the ability to size or move floating sensors.

The Data Menu
Test data from the sensors can be cleared and recorded from the Data menu. The Data menu consists 
of: Clear Data, Grab Data, AutoGrab, Delete Data Points, Load Reference Data, and Assign Sensors to 
Reference Data. This data is later used in reports and graphs.

Data > Clear Data: Erases any stored data in the 
active DataSpace. This change will not be saved until 
the active DataSpace is saved.

Once data has been erased, it cannot be recovered.

CAUTION

Data > Grab Data: Instantly records the current data 
readings. The Grab Data function can be performed 
by clicking on this menu item or by using the Windows 
keyboard shortcut keys Ctrl + G.

3.0 Main Display
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Data > AutoGrab: Allows you to turn AutoGrab off 
or select an interval in which data will be recorded. 
The user is able to choose one of several preset 
intervals or custom configure time intervals. 
AutoGrab only records data when the engine is 
running. The data you grab is saved into the active 
DataSpace and can be printed using the Report 
Generator program, as described in Chapter 6.

Data > Delete Data Points: Deletes data points or 
data phases. If this function is selected, a pop-up 
window will appear. The user can choose to delete 
individual data points or delete entire phases.

To delete Data Points, enter the Data Point number 
and click the Delete button. A confirmation window 
will appear. If the information in the window is 
correct, click OK. The selected point will be deleted. 
Data Points are numbered consecutively.

To delete a Data Phase, select the Delete Phase 
option. A window will list the available phases to 
delete. Highlight the phase to delete and click the 
Delete button. Confirm the selection by clicking OK 
in the confirmation window.

*Data > Load Reference Data: This menu item 
allows the user to load reference data into the 
report from an external data source.

Reference data is data that is typically used for 
comparing results of a test to accepted standards 
when viewing a graph. This data can be imported 
from a DataSpace, a text file created in Excel, or 
created by the administrator using the Reference Data Builder feature found in the Add-Ins menu (Further 
details can be found in Chapter	7.3,	Add-In	Programs). Once reference data has been loaded to the 
DataSpace, the Assign Sensors to Reference Data window will automatically open. The user is given the 
choice of available sensors to assign reference data to.

3.0 Main Display
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*Data > Assign Sensors to Reference Data: After 
reference data is loaded, this menu item will become 
active. It is used to assign the reference data to 
existing sensors.

Once reference data has been designated to a 
specific sensor, it will appear in any graph in which 
that sensor is assigned if the Use Reference Data 
check box is checked in the Graph Properties 
window found in the Report Generator.

IMPORTANT

The Window Menu
From the Window menu, the arrangement of the Main Display window can be modified. The Window menu 
consists of: Default Positions, Show Main Form (which toggles to Hide Main Form), and AutoHide.

Window > Default Positions: If the active windows 
have been modified or moved by the user, selecting 
Default Positions will return them to their default 
display positions.

Window > Show Main Form: To display the Main 
Form, select Show Main Form. After selecting Show 
Main Form, the Show Main Form menu item will 
change to Hide Main Form. To hide the Main Form, 
select the Hide Main Form function, which causes 
the Main Form to be hidden. If the sensors are only 
displayed in the Single Main Form format, the Hide 
Main Form will remain grayed out.

Window > Autohide: Clicking Autohide will reduce 
the floating menu to the “P” icon after a short period of 
time. To reactivate it, simply place your cursor over the 
icon.

3.0 Main Display
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The Add-Ins Menu
The selections in the Add-Ins menu will vary depending on 
the programs installed with your system. Any optional 
component programs that do not come standard will be 
listed under the Add-Ins menu. Programs found in the 
Add-Ins menu are explained in Chapter	7,	Add-In	
Programs.

The Tools Menu
The Tools menu consists of: Convert Sensors to English, Convert Sensors to Metric and Calculator.

Tools > Convert Sensors to English: Refer to Table 3.1 
below for the sensors that are converted when this menu 
item is selected. The sensors listed will be converted to 
the english unit of measure shown in Table 3.1 

Sensor Convert To English Convert To Metric
Torque(s) Converts to Ft-Lbs (Foot-Pounds) Converts to Nm (Newton Meters)
Power(s) Converts to HP (Horsepower) Converts to kW (Kilowatt)
Pressure(s) Converts to PSI (Pound Per Square Inch) Converts to kPa (Kilopascal)
Temperature(s) Converts to F (Fahrenheit) Converts to C (Celsius)

Table 3.1: Sensor Conversations

Tools > Convert Sensors to Metric: Refer to Table 3.1 
above for the sensors that are converted when this menu 
item is selected. The sensors listed will be converted to 
the metric unit of measure shown in Table 3.1.

Tools > Calculator: Opens the Calculator program found 
on the Commander computer.

                       

3.0 Main Display
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The Help Menu
The Help menu consists of: Show Versions, Release Notes, Show Manual, and Go To Program Directory.

Help > Show Versions: Opens the 
Executable Versions window (below) 
displaying the current version specifications 
of the software.

             

Help > Release Notes: Opens a .txt file 
that contains the historical changes to 
the software program. This is used as a 
reference file by Power Test employees.

Help > Show Manual: Opens a PDF file 
of the software manual supplied with your 
equipment. Adobe Acrobat Reader was 
installed with the system software.

Help > Go To Program Directory: Opens 
the program directory or the folder on the 
Commander computer where all of the files 
pertaining to the PowerPro software are 
located. This provides a quick link to this 
folder in order to locate a specific file type or 
to make changes.

3.0 Main Display
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4.0 PowerPro-SF Interface
4.1 PowerPro-SF Interface Window
The PowerPro-SF Interface window provides essential control functions for the dynamometer. This window 
identifies the dynamometer’s active load control mode and the current setpoint. It is possible for a user at 
the Commander computer to control the dynamometer using the mode buttons and the input box directly 
from the PowerPro-SF Interface window. Additionally, the dynamometer tuning parameters, torque and 
pressure calibrations, and the relays for ancillary components can all be accessed from this window.

Controlling the Dynamometer
There are two methods for manually controlling the dynamometer and/or engine directly from the  
PowerPro-SF Interface. The first method is by entering a number in the Setpoint Entry box directly above 
the Start, Home, and Engine Stop buttons. Entering a value in this window and pressing enter on the 
keyboard will move the yellow slide bar to the desired setpoint. A blue bar will display the progress of the 
change being made. The second method for controlling the dynamometer and/or engine is by clicking on 
the slide bar and dragging it to the desired setpoint. As the slide bar is moved, its position will be displayed 
in the Setpoint Entry box. A blue bar will display the progress of the change being made. Additionally, 
clicking on the arrows at the top and bottom of the slide bar will move the bar 5% for each click.
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	 	The	system	can	only	be	controlled	using	the	slide	bar	in	the	Throttle	Position	and	
Dynamometer	Valve	Position	Modes	as	described	below.Note

Throttle Control Modes
There are two standard and two optional methods by which the engine operating speed may be controlled 
during testing:

 1. Position
   A method of controlling the engine in which the throttle is set at a percentage of the pre-calibrated 

throttle range and is maintained at this position during testing. 
 2. Act. Torque
   A method of controlling the engine in which an actual torque in lb-ft is entered and the system will 

move the throttle in an effort to maintain the entered value during testing.
 3. Horsepower Mode
   A method of controlling the engine in which a horsepower setpoint is entered and the throttle tries 

to maintain that amount of load, regardless of the dynamometer’s speed or the engines ability to 
achieve that load.

 4. Speed
   A method of controlling the engine in which an actual speed in rpm is entered and the system will 

move the throttle in an effort to maintain the entered value during testing.
 5. Manual
   A method of controlling the engine in which an actual speed in rpm is entered and the system will 

move the throttle in an effort to maintain the entered value during testing.

Dynamometer Control Modes
Whether performing automated or manual setpoint operation, the dynamometer will ultimately be controlled 
by one of the following two modes:

 1. Water In
   A method of controlling the dynamometer in which the dynamometer water valve position is directly 

controlled by valve percentage (manual load method). Load adjustment may be adjusted by using 
the slide bar or entering the percentage value in the Setpoint Entry box.

 2. Engine Speed Mode
   A method of controlling the dynamometer in which an engine speed is entered and the 

dynamometer tries to maintain the engine speed. (Dynamometer must be reading engine speed 
either through the engine’s ECM or the dynamometer’s speed pickup.) If the engine speed is higher 
than the setpoint, the dynamometer will load the engine until the engine speed setpoint is achieved. 
If the engine speed is lower than the setpoint, the dynamometer will unload the engine until the 
engine speed is achieved. This mode is typically used for maximum power pulls.

4.0 PowerPro-SF Interface
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4.0 PowerPro-SF Interface
4.2 PowerPro-SF Interface Window Pull-Down Menus
The PowerPro-SF Interface window consists of the File, Relays, View, and Setup menus.

The File Menu
The File menu allows the operator to load and save sets of tuning parameter values. The File menu 
consists of Open Load Tuning and Open Throttle Tuning. 

File > Open Load Tuning: Opens a previously saved set of 
load tuning parameters.

File > Open Throttle Tuning: Opens a previously saved set of 
throttle tuning parameters.

The Relays Menu
The Relays menu provides control over optional relays. 
The selected relays can be controlled from the PowerPro-
SF Controller.
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The View Menu
From the View menu, the user can modify the tuning parameters, adjust the settings, and view the statistics 
of the PowerPro-SF Interface. The View menu consists of: Display, Settings, Calibrate, Load Tuning, 
Throttle Tuning, and Show Ramping.

View > Display: Displays the main user interface for the 
PowerPro-SF Controller Interface. From here the user can 
start and stop data acquisition, select from various throttle 
and dynamometer control modes, and start and stop 
the engine. The name off the current phase is displayed 
below the data acquisition control buttons.

View > Settings: Displays the settings for the PowerPro-
SF Controller Interface as described on the following 
pages. From here the user can start and stop data 
acquisition, select from various throttle and dynamometer 
control modes, and start and stop the engine. The 
name off the current phase is displayed below the data 
acquisition control buttons.

4.0 PowerPro-SF Interface
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4.0 PowerPro-SF Interface
q Low Test RPM: The low point at which 
the data acquisition starts or finishes, 
depending on if it is an up or down sweep.

w High Test RPM: The high point at which 
data acquisition starts or finishes, depending 
on if it is an up or down sweep.

e Step Size RPM: The speed interval (in 
RPM) at which a data point is recorded.

r Inertia ft-lbs sec: Inertia of the spinning 
components of the engine. To calculate 
inertia, refer to the Appendix section of this 
manual.

t Gearbox Ratio to 1: Set gearbox ratio, 
typically 1

y Sweep Ramp Rate: The rate of increase 
(RPM per second) that the system will 
perform the test.

u Cal Files: Select calibration files*

*The selection of a Calibration file in the 
PowerPro-SF interface affects the contents 
of the Use List for AUX sensors, as found in 
the Sensor Properties in the Main Display.

q

w
e
r
t

y

u
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4.0 PowerPro-SF Interface
i Power Correction: The formula by 
which a correction is determined.

o Friction Torque: The torque which is 
produced by frictional forces and opposes 
rotational motion, such as that. Set to 
"Assume 85% efficiency".

1)1!1@1# The values needed to compute 
corrections. These can either be assigned 
fixed values (by checking “Typed value” 
check box) or taken from a sensor (by 
unchecking “Typed value” check box).

1$ Vol/Rev: The displacement of the 
engine used in one revolution of the 
engine. 50% of the volume in a four 
stroke. 100% of the volume in a two 
stroke.

1% Frequency Inputs: Select PPR for 
Speed and PPG for Volume Flow.

1^ Fuel Configuration: Ignore, Add, or 
Subtract to determine total fuel volume 

1& Air Flow Configuration: Select to 
include sensor in airflow

1* Throttle % on Start: The percentage 
of throttle position required to start an 
engine.

i

o

1)

1!

1@

1#

1$

1%

1^

1*

1&
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4.0 PowerPro-SF Interface
View > Calibrate: This selection will open the 
calibration screen allowing the administrator to 
calibrate attached sensors.

The Calibrate window is used for manually 
zeroing the torque, pressures, and auxiliary 
sensors. Clicking the Zero Offset button resets 
the current value to zero. When zeroing the 
torque, make certain that there is no torque 
applied to the dynamometer. Additionally, when 
zeroing the pressures, make certain there is no 
pressure applied to the sensor being calibrated 
at the time of zeroing. Uncoupling the quick 
disconnects will help to ensure that all pressure 
has been relieved.

Calibrating the Sensors
Torque:

 1. Make sure there is no torque being   
  applied to dynamometer.
 2. Attach the calibration arm to the torque arm of the dynamometer.
 3. Zero the torque by clicking on the Zero Offset button.
 4.  Stack a known amount of weight on the calibration arm (200 lbs is recommended). The calibration 

torque is the weight multiplied by the calibration arm length, as measured from the center of the 
dynamometer shaft.

 5.  If the calibration is correct, no change is needed. Proceed with other calibration procedures. If the 
displayed torque is not correct, follow steps 6-8.

 6.  Enter the calibration torque value and click 
on the Adjust Gain button. The Adjust Gain 
button will only become active when a 
number is entered in the box and torque is 
applied to the dynamometer.

 7. Remove weights and calibration arm.
 8. Zero the torque again.

To prevent erroneous calibration, the “Adjust Gain” 
button will only become active when a torque value 
is entered into the box and enough force is being 
applied to the torque sensor you are calibrating.

IMPORTANT
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4.0 PowerPro-SF Interface
Temperature: There is no adjustment for the calibration of the temperature sensors. If a temperature 
is reading incorrectly, try using a different probe. If available, the temperature may be verified with a 
thermocouple simulator. If that does not work, contact your SuperFlow representative.

Pressures:

 1.  Make sure there is no pressure source 
connected to the sensor.

 2. Connect a regulated air supply set to 0 psi.
 3.  Zero the pressure by clicking on the Zero 

Offset button.
 4.  Slowly adjust the pressure regulator to a 

known pressure range near the sensors 
rating.

 5.  Enter the known pressure value into the 
input box for the corresponding sensor 

  and click on the Adjust Gain button.
 6. Slowly bleed off the air supply.
 7. Disconnect the pressure source.

Speed: There is no adjustment for the calibration of the speed sensor. If the speed is reading incorrectly, 
check the cables, connectors, and the gap between the magnetic pickup and the gear. If it is still reading 
incorrectly, repair parts or service may be required. If available, the speed may be verified with a hand 
tachometer.

Speed pickup gap .015"-.020"

An abrupt change in pressure may result in damage 
to the sensor being calibrated. Make certain that 
the regulated air supply is set to zero before 
introducing pressure at a slow pace. When finished 
calibrating, slowly bleed off the air supply before 
removing from the sensor being tested.

WARNING
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View > Load Tuning: Displays the dynamometer         
tuning parameters, shown below. The PowerPro software 
utilizes a Proportional Integral Derivative controller. The 
PID controller compares a measured value from a process 
with a reference setpoint value. The difference or error 
signal is then used to calculate a new value for the throttle 
or valve. The PID loop occurs many times per second.

The Proportional (P) or gain positions the throttle or valve at a percentage proportional to the error. The 
Integral (I) is the rate at which the dynamometer will reach that setpoint. The Derivative (D) controls the 
rate of change and is seldom used.

Determining the appropriate settings for P and I can be a difficult task. A simple method for tuning is to 
first set the I and D values to zero. Increase the P until the system begins to oscillate and then divide by 2. 
Next, increase I until oscillation starts and divide by 2. A fast PID loop tuning usually overshoots slightly to 
reach the setpoint more quickly; however, some systems cannot accept overshoot. If this is the case, the 
tuning will need to be slower.

View > Throttle Tuning: Displays the throttle tuning 
parameters, shown below. A detailed description of the 
tuning process is described above.
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4.0 PowerPro-SF Interface
View > Show Ramping: Displays the Ramping, or         
percentage of change per second of the value being 
changed.

ex. Entering a throttle value of 50 in the Setpoint Entry 
Box and a value of10 in the %/sec Entry Box will increase 
the throttle percentage by 10percent every second, 
acheiving the set value of 50% throttle in five sec-onds.

The Setup Menu
From the Setup menu, the user can turn the Auto Sweep 
function on or off or switch to the Step Test function screen.

Setup > Auto Sweep: Prepares the PowerPro-SF 
Controller Interface for the Auto Sweep function. Sweep 
parameters are determined in the Settings window.
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Setup > Step Test: Prepares the PowerPro-SF 
Controller Interface for the Step Test function. Step 
parameters are determined in the Settings window 
or can be typed directly into the boxes provided. 

NOTE: Ensure throttle (QuikStik) is in the idle 
position before clicking on the Step Test menu item. 

When the Step Test menu item is selected, the 
throttle mode will be set to MANUAL and the LOAD 
SPEED set point will be set based on the Start 
parameter.

After the Step Test parameters have been correctly 
entered;

 1.  The operator adjusts throttle to the desired 
position. 

 2.  Then pressing the UP or DOWN buttons 
increases or decreases the load to bring 
the speed to the next desired set point 
based on the Step Size and Ramp Rate 
parameters. 

At any time the operator can change the Current 
Set Point, Start, Stop, Set Size and Ramp Rate 
values by typing a new value into the appropriate 
box and pressing the Enter key.

NOTE: Values that are directly typed in are NOT 
saved back to the Settings window.

4.0 PowerPro-SF Interface
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5.0 Pattern Runner
5.1 The Pattern Runner Interface Window
The Pattern Runner program allows the user to 
create, load, save, and execute Patterns. Patterns 
are pre-configured load and speed setpoints that 
are designed to automatically run in order. Each 
of these setpoints represents an action executed 
by the Controller Interface. Once a Pattern has 
been created, that Pattern is used to run individual 
commands of the Controller Interface.

Example of a PowerPro Test Pattern

Each row represents one point in the Pattern and is divided into as many as five columns.

 •  The first column represents the Point or 
step of the Pattern. ex. 1), 2), etc. 

 •  The second column represents the Throttle	
mode. ex. Th: represents the Throttle 
position during the test. The throttle value 
can be set by either the percentage (%) of 
the throttle that is desired or by a set speed 
(rpm).

 •  The third column represents the Unit	of	
Measure for each Control mode. ex. hp, rpm or %. In the example above, V: represents position 
of the load control valve. There are four settings for determining the valve position: Valve position, 
Torque, Power, and Speed.

 •  The fourth column represents the Duration or the elapsed time during each step of the Pattern. ex. 
30, 01:00, etc. In the example above, Wait represents the Duration.

 •  Column five indicates whether or not data will be recorded, including activation of the AutoGrab 
feature.

A thorough understanding of the dynamometer 
load and throttle controls, modes of operation, and 
effects on the engine are required before creating 
new patterns. When creating new patterns, it is 
recommended to insert many small steps between 
changes in rpm and load. It is also recommended 
that the time interval (point duration) is set long 
enough to allow for each step to stabilize before 
advancing to the next.

IMPORTANT

The units for each of these settings are selected 
from the Sensor Properties window of the Main 
Display. To access the Sensor Properties window, 
right-click on the sensor and select Properties. 
Then choose the appropriate unit from the Units 
tab.

IMPORTANT
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5.0 Pattern Runner
The example (right) uses the Throttle Speed mode for points 
1-11 and point 15 and the Throttle Percentage mode for 
points 12-14. In addition, the Dyno Valve Percentage mode is 
used for points 1-3 and 14-15, the Valve Torque mode is used 
for points 4-11, and the Dyno Speed mode is used for points 
12-13.

5.2 Pattern Runner Window Pull-Down Menus
The Pattern Runner window consists of two pull down menus: the File and Edit menus.

The File Menu
There are four options within the File menu, New, Open, Save, and Save As.

File > New: Clears the active Pattern to allow the 
user to create a new Pattern, as explained on
page	41.

File > Open: Allows the operator to open an 
existing Pattern.

File > Save: Overwrites the active Pattern with a 
file having the same name.

Once changes have been saved and the original 
file has been overwritten, the original file cannot be 
retrieved.

CAUTION
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5.0 Pattern Runner
File > Save As: Saves a copy of the active          
Pattern as a new Pattern. The user will be prompted 
to name the new file before saving.

The Edit Menu
There is one option available for the Edit menu: Edit Full Pattern.

Edit > Edit Full Pattern: This allows the operator 
to edit the active Pattern. Selecting Edit > Edit Full 
Pattern brings up the Edit Pattern window. The 
procedure for editing an existing Pattern is similar to 
creating a new Pattern, see Chapter 5.3 for details.

5.3 Creating a New Pattern or Editing an Existing Pattern
A new Pattern can be created from scratch or by modifying an existing Pattern and then saving as a new 
file name. To create a new Pattern from scratch, click on File > New in the Pattern Runner window. To 
modify an existing Pattern, select File > Open and open the Pattern to be modified. In either case, you 
have the same options available to choose from and edit.
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q Current Point: Indicates the current point in the Pattern being edited. Points can be added, deleted, or 
navigated using the function buttons at the bottom of the Edit Pattern window. 

w Control Mode Buttons: Indicates which method of control is being used for the current point in the 
Pattern.
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e Stability Frame: The settings entered in the Stability frame cause the system to wait to perform the 
functions specified in the current point until the requirements specified by the administrator are met. The 
Stability frame includes the Wait for Sensor, Wait for Setpoint, and None boxes.

If the Wait for Sensor box is clicked, the current point will be held until a selected sensor has reached a 
predetermined value (Goal input box) within a certain tolerance (Tolerance input box) for a certain duration 
(Wait Stability Secs input box). When using Wait for Sensor, the Wait Stability Secs won’t begin counting 
down until the sensor value is within the range defined by the Goal and Tolerance. If the sensor value drifts 
outside the range during the wait time, the wait time will start over once the point is back within the range.

If the Wait for Setpoint box is clicked, the current point will be held until its value is reached within a 
certain Tolerance (Tolerance input box), for a certain duration (Wait Stability Secs input box). When using 
Wait for Setpoint, the Wait Stability Secs won’t begin counting down until the indicated control mode value 
is within the range determined by the setpoint and the tolerance. If the control mode value drifts outside the 
tolerance during the wait time, the wait time will start over once the control mode value is back within the 
range.

r Operator Prompt Frame: The settings 
entered in the Operator Prompt frame allow the 
administrator to display instructions for the operator 
and to pause the current Pattern until the operator 
responds. The Operator Prompt frame includes the 
Operator Prompt input box and the Show Status on 
Handheld, Wait for Continue, and Allow skip of ___ 
points check boxes.

 If a Pattern is suspended or restarted after a 
particular sensor or setpoint has been reached, the 
system may not be able to resume if the sensor or 
setpoint value has traveled outside of its specified 
goal and tolerance. ex. If a point was set to begin 
when the engine temperature has reached 180° 
with a setpoint of 180 and a tolerance of five, and 
the Pattern has been suspended after the engine 
temperature has reached 205°, the point will not 
proceed to the next point if the test is restarted 
without allowing sufficient time for the engine to 
cool.

IMPORTANT

5.0 Pattern Runner
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If the Wait for Continue box is checked, the Pattern will not proceed to the next point until the operator 
touches the Continue button.

If the Allow Skip of Points ___ box is checked, the Skip button will appear. If the operator touches the 
Skip button, the Pattern will skip the indicated number of Pattern points.

t AutoGrab Frame: The AutoGrab function allows the administrator to determine if data is to be grabbed 
at the end of each point.

If No Change is clicked, it keeps the AutoGrab setting the same as in the preceding Pattern point.

If At the start of point grab data every ___ secs is clicked, entering a value defines the time interval that 
data will be captured during the current Pattern point.

If Off is clicked, the AutoGrab feature is disabled.

y Point Duration Input Box: In this method, the administrator simply enters how many seconds the 
current point is to be held before continuing to the next point. The number of seconds is entered in the 
Point Duration input box.

u Grab Data at the End of This Point Input Box: 
Selecting this will grab a datapoint at the end of the 
current point in the Pattern. It is possible to use any of the above methods for 

determining point duration simultaneously. The 
dynamometer will first try to satisfy the Stability 
settings, then the Operator Prompt settings, and 
finally the Point Duration settings.

IMPORTANT
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i Function Buttons: Points can be added, deleted, or navigated through using the function buttons as 
explained below:

  Previous: Makes the preceding Pattern point active (if one exists) to allow it to be edited. Click once to 
restart the current point. To activate the previous point, click twice.

 Next: Advances to the next Pattern point (if one exists) to allow it to be edited.

 Add: Inserts a copy of the current Pattern point and makes it active for editing.

 Delete: Deletes the current Pattern point.

 OK: Exits the Edit Pattern window. 

o Setpoint Input Box: Indicates the setpoint for the current point in the Pattern.

a Ramp/Sec % Input Box: If ramping is enabled, this input box allows the administrator to change the 
ramping or percentage of change per second of the value being changed.

s Phase Drop-Down Menu: Phases allow acquired data to be grouped for reporting purposes. To assign 
the data collected during the current point to a particular phase, simply select the desired phase from the 
drop-down menu. To create a new phase, type the name of the new phase in the drop-down menu. Phases 
are explained in detail in Chapter 6, Report Generator.

5.0 Pattern Runner
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d "Go to" Info Frame: 
When "None" is clicked in Stability, Go To allows 
the administrator to create a new point that makes 
the Pattern go to a specific point (Go To point 
number input box) in the pattern. This allows the 
administrator to duplicate stages of a Pattern without 
having to create them again. How many times a 
stage of the Pattern repeats is determined by the 
number entered in the Go To Count input box.
When "Wait for sensor" is clicked in Stability, the Go 
To point will check to see if the predetermined value 
(Goal input box) within a certain tolerance (Tolerance input box) has been reached for the selected sensor. 
If the sensor value is within the range defined by the Goal and Tolerance the Pattern steps will continue. If 
the sensor value is outside the range, the Pattern will go to the point specified (Go To point number input 
box). If the sensor does not meet the predetermined value after a stage of the Pattern has been duplicated 
based on the value entered in the Go To Count input box, the Pattern steps will continue.

f Digital Outs Frame: This frame allows the administrator to automatically turn relays on/off as part of a 
point.

g Go To Point # Input Box: Allows the administrator to enter a pattern point number into the input box. 
Once the point number is entered, pressing the "Go to Point #" button will load that point of the pattern.

h Command Prompt Input Box: Allows the administrator to enter specialized text that sends a command 
to an auxiliary programs that may be used in conjunction with the system.

5.0 Pattern Runner
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5.0 Pattern Runner
Saving a Pattern
When finished creating or editing the Pattern, it will be saved with the active Template or DataSpace. The 
Pattern can also be saved as its own file by selecting File > Save As from the Pattern Runner window.

Running a Pattern
When all of the Pattern points have been edited and saved, the Pattern is now ready to run. To run a 
Pattern, click on the Play button. This will display the time remaining for the current Pattern point. Clicking 
the Pause button pauses the current Pattern and changes the function of the Play button to Stop. To 
resume the Pattern, click the Pause button again. To stop the Pattern, click on the Stop button. The 
<<Previous and Next>> buttons are used to navigate to different points in the Pattern.
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6.0 Report Generator
6.1 The Report Generator Program
A copy of the data recorded during a dynamometer test should be saved following each test session. 
The Report Generator allows the operator to arrange the data into a meaningful visual format. Customer, 
engine, and setup information can be put into user tables and paragraphs. The information gathered during 
a test can then be arranged in a data table, spreadsheet, and/or graph. Report formats can be created and 
edited before or after a DataSpace has been created.

Report Generator Window

There are two types of information tables: a user table and a data table. A user table provides blanks for 
the operator to enter specific information about the test being performed. This can include, but is not limited 
to: customer information, engine information, and test specific information. A data table contains information 
gathered from the attached sensors during a test and displays only the information that is specified for that 
particular data table, such as maximum and minimum values.

The data gathered during a test can also be arranged in a spreadsheet, graph, and/or grid. A spreadsheet 
is a computer generated arrangement of the test data into rows and columns. A graph is a drawing 
representing the relationship between two sets of data. One set, such as gathered information, is 
represented on a vertical scale or axis, the other, such as time, is represented on a horizontal scale or 
axis. Information can also be entered into operator-designed grids. In most circumstances, an operator will 
design a grid similar to a manufacturer's test report. The finished grid will display a combination of manually 
entered and test generated data.

In addition to tables, graphs, spreadsheets and grids, information can also be entered into a paragraph. A 
paragraph is typically used to enter notes, disclaimers, and descriptions, relating to a specific test or stage 
of testing.
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6.2 Report Generator Window Pull-Down Menus
The Report Generator window consists of the File, Edit, View, Import, Export, and Ignore List menus.

The File Menu
The File menu allows the user to access the Report Generator print features. The menu consists of: PDF 
Setup, Create PDF, and Print Screen. 

File > PDF Setup > Landscape: This selection 
allows the user to select if the PDF file will be set as 
Portrait or Landscape. By default PDF files are set 
to Portrait. If the user check marks Landscape, PDF 
files will be set to Landscape.

File > PDF Setup > Font Size: This selection 
allows the user to select between predefined font 
sizes; Small, Medium, Large, and Extra Large.

File > Create PDF: Creates and opens a PDF 
file of the report. From the preview, the user 
can choose to save or print a hard copy of the 
report. Reports can be configured to display your 
company’s logo and contact information. Contact 
your Power Test representative for assistance in 
creating a custom header.

File > Print Screen: Sends a snapshot of the entire 
Commander computer screen to the printer.

6.0 Report Generator
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The Edit Menu
The Edit menu consists of two selection: Report and Phase Name.

*Edit > Report: This function allows the 
administrator to modify the active data report. Click 
on Edit > Report and a new window will appear. 
The Edit Report window (below) allows the user to 
configure the printed reports and the entry fields 
of: user tables, data tables, graphs, spreadsheets, 
paragraphs and grids.

Using the Edit Report Window
From the Edit Report window, the user can move, add, delete, copy, and/or edit sections. The information 
displayed on the report will display as it appears in the list. Clicking on a section highlights that section and 
enables the function buttons on the left side of the window.

Edit Report Window Function Buttons

q

w

e

r

t

y

q Move Section Up Button: Clicking this button will move the highlighted section up, changing the order 
in which information appears on the final report.

w Move Section Down Button: Clicking this button will move the highlighted section down, changing the 
order in which information appears on the final report.

e Delete Section Button: Clicking this button will delete the highlighted section.

6.0 Report Generator
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r Add Section Button: Clicking this button will open up the Add Section window 
(right), allowing the user to add one of seven section types: User Table, Data 
Table, Graph/Spreadsheet, Paragraph, Page Break, Grid, and Event Finder.

t Copy Section Button: Clicking this button makes a copy of the highlighted 
section and all of its properties. This is useful for creating a similar section without 
having to create it new.

y Edit Section Button: Clicking this button or double-clicking on any highlighted 
section allows the user to edit that particular section of the report.

Creating or Editing Report Sections
To create a new report section, click the Add Section button on the Edit Report window (shown on  
page	49), select the section type you want to create from the Add Section window, and click OK. Next, with 
the newly created section highlighted, either click on the Edit Section button on the Edit Report window or 
double-click the selection. This will open a new properties window where you can edit the new section.

To edit an existing report section, select the desired section from the Edit Report window (shown on  
page	49) and either click on the Edit Section button or double-click on the highlighted selection.

Report Section Properties Windows
When you select a report section from the Edit Report window and either click on the Edit Section button 
or double-click the selection, a new properties window will open up that gives you options to edit the 
report section. Each type of report section (User Table, Data Table, Graph, Spreadsheet, etc.) has its own 
properties window. On the following pages, each report section's properties window is described. It is in 
these windows that a user customizes how the data gathered will be presented in the generated report.

6.0 Report Generator
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Creating or Editing a User Table

To create a new user table, click the Add Section button on the Edit Report window (shown on page	49), 
select User Table from the list of section types, and click OK. Next, with New User Table selected, either 
click on the Edit Section button on the Edit Report window or double-click on the highlighted selection. This 
will open a new properties window where you can edit the new section.

To edit an existing user table, select the desired user table from the Edit Report window (shown on  
page	49) and either click on the Edit Section button or double-click on the highlighted selection.

User Table Properties
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q Table Name Input Box:
The Table Name input box is where the operator can name a new user table or rename an existing table. 
To name or to change the name of a user table, highlight the current text in the Table Name input box and 
type over it with the new name.

w Field Name Input Box:
The Field Name input box is where the operator can change the name of a report field. To change the 
name of a report field, click on the report field name to be changed in the Report Fields list. Then, with the 
current field name highlighted in the Field Name input box, type over the current name with the new name.

e Columns Frame:
The Columns frame allows the operator to choose 
how many columns are assigned to the user table.

It is recommended to keep the number of columns 
in a user table a multiple of the number of fields. i.e. 
If there are 4 report fields, it is recommended you 
choose 1, 2, or 4 columns. This will help to ensure 
that the data is presented in an organized manner.

IMPORTANT

6.0 Report Generator



52

4060 Dixon Street ▪ Des Moines, IA 50313 USA 
phone: (515) 254-1654 ▪ fax: (262) 246-0436

www.superflow.com

r Report Field Buttons:
Report fields can also be moved up or down using the Navigational buttons or deleted from the user table 
using the Delete Section button. Clicking the Add Section button adds a report field.

t Report Field List:
The Report Field list displays all the report fields that the operator can enter specific information into 
regarding the test being performed. To add a report field, click on the Add Section button. A user table is 
limited to 12 report fields. Report fields can also be moved up or down using the Navigational buttons or 
deleted from the user table using the Delete Section button.

6.0 Report Generator
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Creating or Editing a Data Table

To create a new data table, click the Add Section button on the Edit Report window (shown on page	49), 
select Data Table from the list of section types, and click OK. Next, with New Data Table selected, either 
click on the Edit Section button on the Edit Report window or double-click on the highlighted selection. This 
will open a new properties window where you can edit the new section.

To edit an existing data table, select the desired data table from the Edit Report window (shown on  
page	49) and either click on the Edit Section button or double-click on the highlighted selection.

Data Table Properties
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q Table Name Input Box:
The Table Name input box is where the operator can name a new data table or rename an existing table. 
To name or to change the name of a data table, highlight the current text in the Table Name input box and 
type over it with the new name. 

w Columns Frame:
The Columns frame allows the operator to choose 
how many columns are assigned to the data table. It is recommended to keep the number of columns 

in a data table a multiple of the number of fields. i.e. 
If there are 4 report fields, it is recommended you 
choose 1, 2, or 4 columns. This will help to ensure 
that the data is presented in an organized manner.

IMPORTANT

6.0 Report Generator
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e Function Frame:
The Function frame defines which data points will be displayed in the data table. There are six options an 
operator can select from, including:

  First: This will display the first value of the sensor selected. If the Individual Phases check box is 
selected, it will display the first value of the sensor selected for each selected phase.

  Last: This will display the last value of the sensor selected. If the Individual Phases check box is 
selected, it will display the last value of the sensor selected for each selected phase.

  Delta: This will display the difference between the first and last value of the sensor selected. If the 
Individual Phases check box is selected, it will display the difference between the first and last value of 
the sensor selected for each selected phase.

  Average: This will display the average value of the sensor selected. If the Individual Phases check box 
is selected, it will display the average value of the sensor selected for each selected phase.

  Peak: This will display the largest value of the sensor selected. If the Individual Phases check box is 
selected, it will display the largest value of the sensor selected for each selected phase.

  Low: This will display the lowest value of the sensor selected. If the Individual Phases check box is 
selected, it will display the lowest value of the sensor selected for each selected phase. 

r Reference Sensor Frame:
The Reference Sensor frame will display a particular sensor's values and its correlation to another 
sensor’s greater or lower value. i.e. Speed at Peak Torque. To display reference sensor data in the 
generated report, choose a reference sensor from the drop-down menu. The list of sensors available as 
reference sensors is the same as the list of sensors found in the Available Sensors list. When the desired 
reference sensor has been selected, click on Hi Ref to display the peak value or Lo Ref to display the low 
value.

t Phases:
A Phase represents a segment of the data gathered during a test. The Phases section displays the list of 
stored phases from the current DataSpace. Selecting a phase will include it in the generated report. 

y Individual Phases Check Box:
If the Individual Phases box is unchecked, all function values for the included data table sensors will be 
calculated by grouping data from the selected phases. If the Individual Phases box is checked, the function 
values will be calculated on a per phase basis.

u Available Sensors List:
Report data is gathered from the sensors displayed in the Available Sensors list. This list displays all 
of the sensors connected to the system at the time of the reports creation. (Available sensors may vary 
depending on the version of software.)

6.0 Report Generator
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ioa Data Table Sensors List:
The Data Table Sensors list (o) displays all of the sensors whose data will be displayed on the generated 
report. To add a sensor to the Data Table Sensors list, first click on a sensor from the Available Sensors list 
(u). Next, select a function to be performed on the sensor from the Function frame (w). Then click the Add 
button (i) to include the selected sensor and function to be performed to the Data Table Sensors list (o). 
To remove a sensor from the Data Table Sensors list (o), select the sensor so it becomes highlighted and 
then click the Remove button (a).

s Navigational Buttons:
To change the order in which the data table sensor information appears on the generated report, highlight a 
sensor in the list and click on the navigational buttons to the left of the Data Table Sensors list to move it up 
or down.

6.0 Report Generator
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Creating or Editing a Graph

To create a new graph, click the Add Section button on the Edit Report window (shown on page	49), 
select Graph/Spreadsheet from the list of section types, and click OK. Next, with New Graph/Spreadsheet 
selected, click on the Edit Section button on the Edit Report window or double-click on the highlighted 
selection. This will open a new properties window where you can edit the new section.

To edit an existing graph, select the desired graph from the Edit Report window (shown on page	49) and 
either click on the Edit Section button or double-click on the highlighted selection.

Graph Properties
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q Heading Input Box:
The Heading input box is where the operator can name a new graph or rename an existing graph. To name 
or to change the name of a graph, highlight the current text in the Heading input box and type over it with 
the new name.

6.0 Report Generator
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w Section Type Frame:
The Section Type frame is where the operator defines whether they want the gathered data displayed in a 
graph or spreadsheet. In the Section Type frame, select Graph.

e Graph Properties Frame:
The Graph Properties frame is where the operator can choose which sensors to display on the X-Axis of 
the graph. The X-Axis drop-down menu contains the sensors available for display on the X-Axis (horizontal) 
of the graph. The graph can only display one sensor on the X-Axis. Clicking on the Hide Symbols check 
box will create lines on the graph without showing a symbol at the individual points. If the Plot Individual 
Phases box is checked, each included sensor will be graphed with multiple lines corresponding to each 
phase selected. If the Plot Individual Phases check box is left unchecked, the graph will show each 
included sensor as a continuous line throughout all of the phases selected.

r Use Reference Data Check Box:
Clicking the Use Reference Data check box will plot reference data on the graph in addition to the data 
being recorded during the test. Reference data is data that is typically used for monitoring and comparing 
the results of a test. Instructions for creating and loading reference data can be found in Chapter	7.3,	Add-
In	Programs.

t Show Grid Lines Check Box: 
The user has the option to show grid lines in the graph or not by clicking the Show Grid Lines check box.

y Scale Axes Frame:
The Scale Axes frame is where the operator specifies the Y and/or Y2 axis options for displaying data on 
the graph. By default, the Auto function only displays data in the range from which it was obtained. The 
Zero option displays data from a range of zero to the highest point where data is obtained. The Define 
option allows the operator to define the minimum and maximum range to display data.

u Phases List:
A phase represents a segment of the data gathered during a test. The Phases frame displays the list of 
stored phases from the current DataSpace. Selecting a phase will include it in the generated report.

i Height/Width Input Boxes:
The user has the option of setting the height and width of the graph, which determines the size of the graph 
on the generated report. 

o Available Sensors List:
The Available Sensors list displays the sensors available for display on the Y-Axis (vertical). This list 
displays all of the sensors connected to the system at the time of the reports creation and data is gathered 
from the sensors displayed in the list. (Available sensors may vary depending on the version of software.)
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oasg Included Sensors List:
The Included Sensors list (s) displays the sensors that will be graphed on the Y-Axis. To add a sensor to 
the Included Sensors list, click on a sensor from the Available Sensors list (o), then click the Add button 
(a). To remove a sensor from the Included Sensors list, click on the sensor to be removed, then click the 
Remove button (g).

d Y2 Check Box:
The Y2 check box allows the operator to display a second sensor’s data on the Y2-Axis (vertical, right) 
of the graph. To assign a sensor to the Y2-Axis, click on the sensor you want to display in the Included 
Sensors box, then click the Y2 check box.

f Navigational Buttons:
To change the order in which the data table sensor information appears on the generated report, highlight a 
sensor in the data table sensors list and click on the Navigational Buttons to move it up or down.

h Copy To Graph View Button:
Clicking on the Copy To Graph View button takes the data created from the report and displays it in a new 
window. The New Graph View will have all of the same functions and properties of the graph it was created 
from. A New Graph View displays recorded data from a test and is refreshed every time a data point is 
recorded. This is different from the Real-Time Chart, which displays data regardless if data points are 
recorded or not.

Clicking the Copy To Graph View button opens a 
graph in a new window. Any changes made to the 
new graph will not be saved as part of the report. 
Consequently, any changes made to the graph 
from the Graph Properties window will not appear 
on the new graph unless the Copy To Graph View 
button is clicked again.

IMPORTANT

6.0 Report Generator
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6.0 Report Generator
Creating or Editing a Spreadsheet
To create a new spreadsheet, click the Add Section button on the Edit Report window (shown on page	49), 
select Graph/Spreadsheet from the list of section types, and click OK. Next, with New Graph/Spreadsheet 
selected, either click on the Edit Section button on the Edit Report window or double-click on the 
highlighted selection. This will open a new properties window where you can edit the new section.

To edit an existing spreadsheet, select the desired spreadsheet from the Edit Report window (shown on 
page	49) and either click on the Edit Section button or double-click on the highlighted selection.

Spreadsheet Properties
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q Heading Input Box:
The Heading input box is where the operator can name a new spreadsheet or rename an existing 
spreadsheet. To name or to change the name of a spreadsheet, highlight the current text in the Heading 
input box and type over it with the new name.

w Section Type Frame:
The Section Type frame is where the operator defines whether they want the gathered data displayed in a 
graph or spreadsheet. In the Section Type frame, select Spreadsheet.
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6.0 Report Generator
e Spreadsheet Properties Frame:
In the Spreadsheet Properties frame, the operator has the option of clicking on the Enable Grouping check 
box. If the Enable Grouping check box is selected, the user has the option to select a sensor from the 
Key Sensor drop-down menu (the sensor that data is matched to, typically speed) and whether the data is 
Grouped by Sensor or Grouped by Phase in the generated report. By selecting Group By Sensor, the data 
is paired by sensors and displayed under each phase. By selecting Group By Phase, the data is grouped 
by phase under each sensor. If the Enable Grouping check box is not selected, the included sensors will 
display as a continuous column throughout the whole spreadsheet.

r Phases List:
A phase represents a segment of the data gathered during a test. The Phases frame displays the list of 
stored phases from the current DataSpace. Selecting a phase will include it in the generated report.

t Copy To SS View Button:
Clicking on the Copy To SS View button takes the data created from the report and displays it in a new 
window. The New Spreadsheet will have all of the same functions and properties of the spreadsheet it was 
created from. A New Spreadsheet displays recorded data from a test and is refreshed every time a data 
point is recorded.

y Available Sensors List:
The Available Sensors list displays the sensors available for display on the Y-Axis (vertical). This list 
displays all of the sensors connected to the system at the time of the reports creation and data is gathered 
from the sensors displayed in the list. (Available sensors may vary depending on the version of software.)

yui1) Included Sensors List:
The Included Sensors list (i) contains the sensors that will be displayed on the spreadsheet. To add a 
sensor to the Included Sensors list, click on a sensor from the Available Sensors list (y), then click the Add 
button (u). To remove a sensor from the Included Sensors list, click on the sensor to be removed, then 
click the Remove button (a).

o Navigational Buttons:
To change the order in which the included sensor information appears on the generated report, highlight a 
sensor in the included sensors list and click on the Navigational Buttons to move it up or down.
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Creating or Editing a Paragraph
To create a new paragraph, click the Add Section button on the Edit Report window (shown on page	49), 
select Paragraph from the list of section types, and click OK. Next, with Paragraph selected, either click 
on the Edit Section button on the Edit Report window or double-click on the highlighted selection. This will 
open a new properties window where you can edit the new section.

To edit an existing paragraph, select the desired paragraph from the Edit Report window (shown on  
page	49) and either click on the Edit Section button or double-click on the highlighted selection.

Paragraph Properties

q

w

e

r

q Paragraph Name Input Box:
The Paragraph Name input box is where the operator can name a new paragraph or rename an existing 
paragraph. To name or to change the name of a paragraph, highlight the current text in the Paragraph 
Name input box and type over it with the new name. 

w Text Input Box:
The Text Input box is where the operator is able to enter any information they want to appear on the 
generated report. To add a paragraph to the generated report, click anywhere in the Text Input box and 
type the information you want to include on the report.

e Browse for Text File Button:
The Browse for Text File button opens a window that displays available text (.txt) files that can be imported 
into the Text Input box. Once you have clicked the Browse for Text File button, choose the file you want to 
import and click Open. This will display all the information from that file in the Text Input box.

r Display on Front Panel:
Selecting the Display on Front Panel check box displays the Paragraph Input box as a tab on the Main 
Form window of the Report Generator. Clicking this tab allows the user to type text into the Text Input box 
without having to go into the Edit > Report menu.
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Creating or Editing a Grid
To create a grid, click the Add Section button on the Edit Report window (shown on page	49), select Grid 
from the list of section types, and click OK. Next, with Grid selected, either click on the Edit Section button 
on the Edit Report window or double-click on the highlighted selection. This will open a new properties 
window where you can edit the new section.

To edit an existing Grid, select the Grid from the Edit Report window (shown on page	49) and either click 
on the Edit Section button or double-click on the highlighted selection.

Grid Edit Menu
The Grid Edit menu consists of three selection: Grid, Column and Row.

Edit > Grid > Dimensions: This selection allows 
the user allows the user to modify the grid. Click on 
Edit > Grid > Dimensions and a new window will 
appear. The Grid Properties window (below) allows 
the user to configure the grid by assigning the 
number of columns and rows.

                                

Edit > Column: This selection allows the user to 
modify the grid's columns. To add a column, click 
on a column in the grid, then click Edit > Column 
> Add > Before or After menu selection. To delete 
a column from the grid, click on the column to be 
removed, then click Edit > Column > Delete menu 
selection.
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Edit > Row: This selection allows the user         to modify 
the grid's rows. To add a row, click on a row in the 
grid, then click Edit > Row > Add > Before or After 
menu selection. To delete a row from the grid, click 
on the row to be removed, then click Edit > Row > 
Delete menu selection.

Cell Options
Right-clicking a cell provides four options for the user to modify the properties of that particular cell. The 
options are: Cell Data, Cell Properties, and Copy/Paste Cell. 

Cell Data: This function allows the user to determine whether the 
cell will display user-entered text or data generated during the test. 
Selecting Text and typing directly into the cell will display the text. 
Selecting Sensor Value will allow the user to select which sensor to 
display and from which phase the information is displayed. 

Cell Properties: This function allows the user to change the 
information displayed from regular type to bold or, if something is 
already bold, it can make it regular type again.

Copy/Paste Cell: This function allows the user to copy 
and paste individual cells into other cells in order to quickly 
reproduce cells with duplicate properties or to copy and 
modify a cell with similar properties.



64

4060 Dixon Street ▪ Des Moines, IA 50313 USA 
phone: (515) 254-1654 ▪ fax: (262) 246-0436

www.superflow.com
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*Edit > Phase Name: This function allows the         
administrator to modify the phase name's used in 
the active data report. Click on Edit > Phase Name 
and a new window will appear. The Edit Phase 
Name window allows the user to rename the phase 
names.

The View Menu
The View menu lists two options: New Graph View and New Spreadsheet View.

View > New Graph View: Automatically creates a 
new graph and opens the Graph View Properties 
window for that graph. See New Graph View 
Properties Window for detailed information on this 
window. The new graph displays recorded data 
from a test and is refreshed every time a data point 
is recorded. This is different from the Real-Time         
Chart, which displays data regardless if data points    
are recorded or not.

New Graph View Options
Right-clicking the new graph will display the Options window 
(next page). The users has the following options for modifying 
the graph:

 Print: Prints the active new graph.

  Symbols: Displays the symbols indicating each point where data has been 
recorded.

  Legend & Title: The legend is displayed at the bottom of the graph and the title is 
displayed at the top of the graph.

  Grid Lines: Displays the grid lines on the graph.

  Undo All Changes: Resets any changes made using the Zoom, Move, and Scale 
functions.

  Zoom: Allows the user to zoom-in on a specific point on the graph while retaining the X-Axis and 
Y-Axis.
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  Move: Allows the graph to be repositioned within the window.

  Scale: Allows the graph to be re-sized; enlarging or reducing the actual size of the graph.

  Show Marker: Allows a red marker line to be placed on 
the graph. The user can position the marker line any where 
within the graph and that positions information will be 
displayed as shown right.

  Properties: Opens the Properties window.

  Add Reference Phase: Opens the window shown lower left. 
From this window, the operator selects a "Dataspace" and 
"Phase" to import into the current graph view for comparison. 
The newly selected data will be shown with a "+" symbol 
(shown lower right) in the beginning of it to indicate it's the 
additional data.

          

  Live Data: Will show current live data in the graph view window.
   • For Power Pro and Power Pro Total Automation systems only.
   • Live data will stream only when in data aquisition mode.
   • Live data will disappear at the end of the sweep and replaced by recorded data.
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New Graph View Properties Window

q Name Input Box:
The Name input box is where the operator can 
name the new graph. To do this, click in the 
Name input box and type in the name.

w X-Axis Drop-Down Menu:
The X-Axis menu contains the sensors available 
for display on the X-Axis (horizontal) of the 
graph. The graph can only display one sensor on 
the X-Axis. 

e Use Reference Data Check Box:
Clicking the Use Reference Data check box 
will plot reference data on the graph in addition 
to the data being recorded during the test. 
Reference data is data that is typically used for 
monitoring and comparing the results of a test. 
Instructions for creating and loading reference         
data can be found in Chapter	7.3,	Add-In	Programs.

r Plot Individual Phases Check Box:
If the Plot Individual Phases box is checked, each included sensor will be graphed with multiple lines 
corresponding to each phase selected. If the Plot Individual Phases check box is left unchecked, the graph 
will show each included sensor as a continuous line throughout all of the phases selected.

t AutoScale Frame: Clicking the Y and/or Y2 box will display data on the graph from a range of zero to 
the highest point where data is obtained. By default, the AutoScale function only displays data in the range 
from which it was obtained.

y Y2 Check Box:
The Y2 check box allows the operator to display a second sensor’s data on the Y2-Axis (vertical, right) 
of the graph. To assign a sensor to the Y2-Axis, click on the sensor you want to display in the Included 
Sensors box, then click the Y2 check box.

u Phases List:
A phase represents a segment of the data gathered during a test. The Phases frame displays the list of 
stored phases from the current DataSpace. Selecting a phase will include it in the generated report.

i Available Sensors List:
The Available Sensors list displays the sensors available for display on the Y-Axis (vertical). This list 
displays all of the sensors connected to the system at the time of the reports creation and data is gathered 
from the sensors displayed in the list. (Available sensors may vary depending on the version of software.)
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o1)1! Included Sensors List:
The Included Sensors list displays the sensors that will be graphed on the Y-Axis. To add a sensor to 
the Included Sensors list, click on a sensor from the Available Sensors list, then click the Add button. To 
remove a sensor from the Included Sensors list, click on the sensor to be removed, then click the Remove 
button.

View > New Spreadsheet View: Automatically         
creates a new spreadsheet and opens the 
Properties window of that spreadsheet. The new 
spreadsheet displays recorded data from a test and 
is refreshed every time a data point is recorded. 
This is different from the Real-Time Chart, which 
displays data regardless if data points are recorded or not.

New Spreadsheet View Options Window
Right-clicking the new spreadsheet will display the Options window (right). The users has the following 
options for modifying the spreadsheet:

 Print: Prints the active new spreadsheet.

  Show Min & Max Values: Displays the maximum column 
values in red and minimum values in blue.

 Properties: Opens the Properties window.

New Spreadsheet View Properties Window

q Name Input Box:
The Name input box is where the operator can 
name the new spreadsheet. To do this, click in 
the Name input box and type in the name.

w Multi-Phase Properties Frame:
If the Enable Grouping check box is selected, the 
user has the option to select a sensor from the 
Key Sensor drop-down menu (the sensor that 
data is matched to, typically speed) and whether 
the data is Grouped by Sensor or Grouped by 
Phase in the generated report. By selecting 
Group By Sensor, the data is paired by sensors 
and displayed under each phase. By selecting 
Group By Phase, the data is grouped by phase 
under each sensor. If the Enable Grouping check box is not selected, the included sensors will display as a 
continuous column throughout the whole spreadsheet.
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e Phases List:
A phase represents a segment of the data 
gathered during a test. The Phases frame 
displays the list of stored phases from the current 
DataSpace. Selecting a phase will include it in 
the generated report.

r Font Size Box:
The size of the font displayed in the new 
spreadsheet can be changed by entering a value 
in this box.

t Available Sensors List:
The Available Sensors list displays the sensors 
available for display on the Y-Axis (vertical). This 
list displays all of the sensors connected to the 
system at the time of the reports creation and 
data is gathered from the sensors displayed in 
the list. (Available sensors may vary depending 
on the version of software.)

yui Included Sensors List:
The Included Sensors list contains the sensors that will be displayed on the spreadsheet. To add a sensor 
to the Included Sensors list, click on a sensor from the Available Sensors list, then click the Add button. To 
remove a sensor from the Included Sensors list, click on the sensor to be removed, then click the Remove 
button.

The	Import	Menu
The Import menu contains one option: Text File.

Import > Text File: If a paragraph has been made 
importable, this menu item will become active and 
the name of the paragraph will be listed in this 
menu. If there is text within the saved paragraph, 
a check mark will appear next to its name. If no 
importable paragraphs are available, the tab will 
display the text “No Importable Paragraphs”.
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The Export Menu
There are three options available for choosing in the Export Menu: As .chm file, Excel, and Text File. By 
selecting these options, the user can export the report to the desired file type.

Export > As .chm file: This menu item gives the 
user the option to export a report as a .chm file. A 
.chm file is a compressed html page. This type of 
file, normally used by Microsoft to create help files, 
is perfect for creating small files that are easily 
e-mailed. By compressing the html page, not only 
is the file size made significantly smaller, it also 
includes all of the support files.

To create a .chm file, simply click on the menu item and choose a file name. The Report Generator will then 
recreate the html page, compress it, and save it to the Program Directory. A .chm file may be requested by 
your Power Test representative when providing technical assistance.

Export > Excel: This allows the operator to export 
data directly into Microsoft Excel. The administrator 
must choose which Excel template will be available 
to the operator to export the data into. All available 
Excel templates (.xlt files) will be listed under the 
arrow of the Select Template menu. 

Export > Text File: This allows the operator to 
export all the data from a DataSpace to a tab 
delimited text file (.txt). By exporting data to this 
type of file, the data may be imported into virtually 
any spreadsheet program. Simply click on the 
Text File menu item, select a file name, and click 
on Save. The default path is C:\Power Test\
Commander 2.0. 

The Excel template must be saved as a .xlt file in 
the Power Test\Commander 2.0 folder and have a 
blank sheet named 'Data' before it will show as a 
selectable template. The 'Data' sheet is where the 
data will be exported into the template.

IMPORTANT

6.0 Report Generator
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The	Ignore	List
The Ignore List shows all of the phases in the 
DataSpace. If a phase is added to the Ignore List, 
the data from that particular phase will not be 
displayed in the entire report and globally ignored 
by the PowerPro software. To eliminate, but not 
delete, any particular phase from the entire report, 
check the phase name under this menu item.
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7.0 Add-In Programs
In this chapter, some Add-In programs will be introduced. For some systems, Security Editor and ECM 
Communicator are standard components. All other Add-In programs are optional, such as the Smoke 
Check Transfer program, Fuel Controller, and Gas Analyzer. All existing Add-In programs are listed in the 
Add-Ins menu in the Main Display window.

The following are some examples of Add-In 
programs available for Power Test Data Acquisition 
Systems. For instructions and specifications for 
specified equipment, please consult the information 
provided with the option.

IMPORTANT

7.1 Security Editor
The Security Editor is an administrative tool used to assign rights to operators. To access the Security 
Editor program, the user must have full administrative rights. The administrator has to log in, even if they 
have already logged in to the main program.

Edit Users 
The administrator can add, delete, or edit user names, passwords, and security levels. 

To add a new user, click Add, and a New User will be added to the list of current users. To delete a user, 
highlight the user name and click Delete. If there is only one user with full administrative rights in the list, 
the program will not allow you to delete that user. If an attempt is made to do so, the following warning will 
appear (bottom right).
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To edit a user’s security levels, highlight the user whose levels you want to edit and click Properties. The 
Edit Security Levels window (below right) will appear, in which the user’s name, password, and security can 
be assigned. Edit the user name and password and check the appropriate boxes to grant those security 
rights to the user. When finished editing, click OK to accept the changes or Cancel to decline them.

If there is only one user with full administrative rights in the list, the program will not allow you to edit their 
security level. If an attempt is made to do so, the following warning will appear (below right).
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7.2 Calculated Sensors 
This program has the ability to take two sensors or typed values and add, subtract, multiply, divide, or 
power the two values. The user must choose a sensor type, determining what type of units to use on the 
new calculated sensor. When a calculated sensor is created, it is permanently added to the list of available 
sensors.
 

A user must be logged in to access the Calculated Sensors program. To begin calculating sensors, click 
View > Edit. Clicking the Add Sensor button will allow the user to configure the sensors. By selecting 
Sensor Input or Typed Input, either a sensor value or a literal value can be used in the calculation. Select 
the calculation function by clicking on the various option buttons in the Operator frame. Clicking the Add 
Sensor button saves the new Calculated Sensor.

To add additional sensors, click on the Add Sensor button. The name of the sensor, as well as its variables 
and calculations used to determine the value of the calculated sensor, can be edited from the Sensor 
Properties function in the Main Display. Additionally, a custom unit can be assigned to a calculated sensor 
from the Sensor Properties function in the Main Display. Any custom unit can be assigned by choosing the 
Custom option button on the Units tab. If the sensor name has been changed, it will not be renamed until 
the DataSpace has been reopened.

If more than one sensor is added, the Previous and Next buttons allow navigation from one calculated 
sensor to the next.

All calculations are performed on the base unit.

When the display unit has an offset relative to the base unit, i.e. 0°C = 32°F, you will have to add a second 
equation where you add in the offset to correct this issue. 

Example of this issue: 20°C - 20°C = ?

   20°C = 68°F          68°F - 68°F = 0°F          0°F = -18°C          20°C - 20°C ≠ -18°C
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How to Fix the Issue: 20°C - 20°C = ?

Eq 1: 68°F - 68°F = "CalcX"           Do not change the unit of Calc0. There is also no need to display it.
Eq 2: CalcX + 32° = 32°F           Select sensor type - "Temperature"
  32°F = 0°C

  20°C - 20°C = 0°C

The result of Eq 2 is only accurate when displayed in °C. If you want to view the results in °F, then view the 
result of Eq 1.

There is no way to remove a sensor. Sensors can 
only be added. If a calculated sensor is no longer 
needed, a new Template must be created from an 
existing Template not containing the calculated 
sensor.

IMPORTANT
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7.3 Reference Data Builder
Reference data is data that is typically used for comparing the results of a test. The Reference Data Builder 
creates a file containing reference data that can be displayed in charts, report graphs, and graph views. 
Reference data can be obtained from an existing DataSpace, a tab delimited file created in a spreadsheet 
program such as Microsoft Excel, or manually entered by the user.

The File Menu
The File menu contains the following options: New, Open, Save, Save As, Import From DataSpace, Import 
Tab Delimited File, and Exit.

File > New: Clears the current reference data file to allow the user 
to create a new reference data file.

7.0 Add-In Programs
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File > Open: Prompts the user to open an existing reference data 
file.

File > Save: Overwrites the current reference data file.

File > Save As: Saves a copy of the current reference data file as 
a new file. The user will be prompted to name the new file before 
saving.

File > Import from DataSpace: This menu item allows the user to 
import reference data into the report from an existing DataSpace 
by opening the Choose Traces and Phases window, as described 
on page	85.
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File > Import Tab Delimited File: This menu item allows the user 
to import reference data into the report from a program such as 
Excel.

File > Exit: Provides the user with the option to save their data 
and closes the Reference Data Builder program.

Importing Reference Data from a DataSpace
To import data from an existing DataSpace, click on File > Import from DataSpace. Once you choose the 
DataSpace file to import data from the Choose Traces and Phases window (below) will appear.

Select the sensors and phases to be included in the reference data file. Assign a preface to the sensor 
name by entering it into the Trace Preface text box (below). When finished, click OK.
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Traces
A trace is a line on a graph representing a 
specific sensor’s values. To add a trace to a 
reference data file, click on the Add Trace 
button. This will open the Add Trace window 
(right). From the Add Trace window, the user will 
be able to assign a name to the new trace and 
select the sensor type.

To edit an existing trace, highlight the Trace and 
click the Edit Trace button. This will open the Edit 
Trace window (right). From the Edit Trace window, 
the user can edit the trace name and sensor type of 
the selected trace. To delete a trace, highlight the 
trace and click the Delete Trace button.

Individual data points can be edited by manually 
entering values directly into the input box. To add 
data points, the user can click on the Insert Data 
Point at End button. Clicking on the numeral to the 
left of the data point will highlight that particular line 
and change the button to Insert Data Point Before 
Selection.

To load reference data into a DataSpace or Template, 
refer to the Data menu section of Chapter 3, The 
Main Display.

IMPORTANT

7.0 Add-In Programs
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Absorber: The device that absorbs the power from the engine. Converts mechanical horsepower to 
thermal horsepower. 

Administrator: The person(s) in charge of creating and editing the PowerPro Data Templates. This 
person(s) has the highest level of security access to the Commander computer and may or may not be 
the person that is actually performing the tests (operator).

BSCF (Brake Specific Fuel Consumption): Rate of fuel flow per measured horsepower.

Commander Computer: The desktop computer that is the “brains” behind the dynamometer. It 
establishes connections between the chassis dynamometer controller, the vehicle’s ECM, and the 
optional fuel measurement system.

DataSpace: Once a Template contains data, it is referred to and saved as a DataSpace.

ECM Communicator: One of the five main windows on the Commander computer main screen 
(although usually minimized). ECM Communicator establishes a connection to the vehicle’s ECM to 
allow for bringing in ECM data. From the ECM Communicator window, detailed information about the 
connection can be viewed.

Engine Speed Mode: A method of controlling the dynamometer in which either the operator or an 
automated  Pattern enters an engine speed value (usually in RPM) and the dynamometer loads the 
engine to that value and maintains it. This mode is generally used for maximum horsepower pulls and 
can only be used when the dynamometer is reading engine speed (either through the ECM or external 
speed pickup).

Fuel Cabinet: Optional equipment that provides gravimetric fuel measurement data. Allows 
measurement of burn rate, BSFC, fuel quality, etc.

Home: A command button on the user interface window that, when pressed, returns the control mode 
to valve position and enters a zero as the setpoint. 

Horsepower Mode: A method of controlling the dynamometer in which a horsepower setpoint is 
entered and the dynamometer tries to maintain that amount of load, regardless of the engine’s speed or 
its ability to achieve that load. This is typically used for endurance testing or warm up and may overload 
the engine if the setpoint is too large. 

Operator: The person(s) that execute the tests and automated Patterns created by the Administrator. 
Will be responsible for securing the test engines, loading a  DataSpace, and executing the Patterns. 
Will generally have a lower level of security access to the Commander computer.

Pattern: The automated “road” that the vehicle will drive during a test. The Pattern is a sequential 
program of setpoints that the vehicle will be put through. The Pattern is created using  Pattern Runner 
by the dynamometer system Administrator.
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Power Mode: A method of controlling the dynamometer in which either the operator or an automated  
Pattern enters a power value (usually in horsepower) and the dynamometer loads the engine to that 
value and maintains it.

PowerPro-SF Controller: Receives and processes signals between the Commander computer and the 
dynamometer.

PowerPro-SF Interface: One of the five primary windows on the Commander main screen. The 
PowerPro-SF Interface provides most of the control functions for the dynamometer. From this window, 
the dynamometer control mode can be changed and viewed and setpoints can be entered and viewed. 
This window also provides access to the tuning parameters, some calibrations, and allows the user to 
activate and deactivate the dynamometer.

Report Format: How the data will be displayed in hard copy format.

Report Generator: One of the five primary windows on the Commander Main Screen. The Report 
Generator allows the user to enter work order data and configure the appearance and content of the 
printed report.

Setpoint: User defined data that determines from which point data is collected or retrieved. Could be 
dependent on speed, etc.

Soft Stop: When activated, sends the dynamometer water valve to zero, gradually unloading the 
dynamometer. Soft Stop does not stop the engine , it only effectively unloads the dynamometer.

Stator: The stationary part of a dynamometer within which the rotor turns.

Template: Basically a blank test. When a dynamometer test is performed, it is done using one of 
several Templates.

Torque: A measurement of twisting force.

Torque Mode: A method of controlling the dynamometer in which either the operator or an automated 
PowerPro Pattern enters a tractive force value (usually in pounds) and the dynamometer loads the 
engine to that value and maintains it.

Tractive Force: A measure of the horizontal pull force exerted by the vehicle; also referred to as draw 
bar pull.

Tuning: A set of parameters that can be modified to adjust the speed and stability of the 
dynamometer’s load control circuit.

Valve Mode: A method of controlling the dynamometer in which either the operator or an automated 
PowerPro Pattern enters a valve position (usually as % of valve open) and the dynamometer maintains 
that valve position.

8.0 Glossary of Terms
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